0151 448 2080
Order by phone - Mon-Fri: 9:00AM-6:00PM

Select CurrencyYour Basket 0 items | £ 0.00 Checkout

Can't wait to try? why not visit one of our 10 PMT House of Rock sister stores

Waves is pleased to announce support for Mac OS 10.4.9.

Published: Fri April 27, 2007  News Feed

All Waves plug-ins are supported for all formats in both Intel-based Mac and Mac PPC.

Logic users on 10.4.9 using Mac PPC: Please note that Waves are still experiencing loading issues with the SSL, V-Series, GTR, Vocal, and MaxxVolume plug-ins on your system. Until Waves solve this issue with Apple, the work-around is to launch Logic Audio-Units Manager and force these plug-ins to load. Then these plug-ins will appear in the Incompatible Plug-ins menu, but they will function properly.

 
 
Please select your country/region

Choose the region you are shopping from to view products in your currency.

We have temporarily suspended processing of EUR payments, all orders will be charged in GBP.

Please select your country/region

Choose the region you are shopping from to view products in your currency.